Llamarada

Tomar de la élite lo que pertenece a todos

Using Gemfiles on Rails 2.x Apps

| Comments

If your Rails 2.X applications stored its gem configuration in the config/environment.rb file and you want to begin using Gemfiles then you need to follow a few simple rules

Gemfile syntax
1
2
3
4
5
6
7
8
9
10
11
#if the line reads like this:
$   gem "authlogic",  :version => '>=2.1.3'

#then in your Gemfile you should put 
$   gem "authlogic",   '>=2.1.3'

#if it reads like this
$   gem 'activerecord-tableless', :lib => 'tableless', :version => '0.1.0'

#then the corresponding Gemfile entry should go like:
$   gem 'activerecord-tableless', '0.1.0', :require => 'tableless'

Easy isnt? Now you only need one more thing

Install your gems
1
$   bundle install

and you are ready to go

Comments